PC DIAG DOS Trial– Quick Reference Guide

Additional documentation:

Complete Manual: http://www.pc-diagnostics.com/documents/PCD_DOS_Manual_10110.doc
(Copy and paste or type these links into your browser, they are case sensitive)
IMPORTANT:

1. You must first read your PCDiag_DOS_Getting_Started_Registration_Activation_Trial_330.doc and prepare your media. Please look for this document in your download. 

How to Boot a Computer from your CD?

Any personal computer can boot from external devices other than the built-in hard drive. 
With PC Diag DOS you may start your PC from your CD instead of a hard drive.

To start your PC from a CD do the following:

1. Create PC Diag (Bootable CD), from you download ISO.
2. Insert it into PC and restart/reboot.

Note: Most of computer systems have a CD booting priority by default. 
3. If PC Diag doesn't start, change the BIOS boot order so that CD is listed first.

About Boot Priority (Boot from CD-ROM)

To boot from a CD, make sure that the device has the boot sequence priority over the hard drive.

BIOS (Basic Input Output Subsystem) is a programmable chip that controls how information is passed to various devices in the computer system. 

ALTERNATIVE METHODS OF ENTERING THE BIOS TO SET BOOT PRIORITY, READ SEVERAL EXAMPLES BELOW IF YOU ARE UNFAMILIAR WITH THIS PROCESS:

To Enter the BIOS press the "Del" button on your keyboard. Alternatives are "F1", "F2", "Insert", and "F10". Some PC's BIOS might even require a different key to be pressed. Commonly a PC will show a message like "Press [Del] to enter Setup" to indicate that you need to press the "Del" key. Some AMI BIOS require you to enable the option "USB Keyboard Legacy support"! 
For AMI BIOS:

· You may have to Go to "Feature Setup". "Enable" these options: "USB Function Support", 
"USB Function for DOS" and Go to "Advanced Setup". 
Set the "1st Boot Device" to "CD
For PHOENIX/AWARD BIOS:

· Go to "Advanced BIOS Features". Go to the "1st Boot device" and set it to CD". You may not have to do it in this order or not at all.
Some computer manufacturers allow you to select the device that contains the boot sequence from a special device selection menu. The example below uses a Dell system board.

To set boot priority using a device selection menu:

1. When the computer starts to boot up, after the manufacturer's ID screen, press F12 several times. The device selection menu appears.

2. Use the up and down arrows to select CD-ROM. 

3. To boot from the selected device, press ENTER. 

Note: Using an incorrect BIOS setting can cause a system malfunction. Please follow the BIOS guide provided with your computer motherboard. If you read these instructions and you are not sure how to change a setting, it is better to leave it as the default setting.

A typical method to access the BIOS settings screen is to press ESC, F1, F2, F8 or F10 during the boot sequence.

BIOS settings allow you to run a boot sequence from a floppy drive, a hard drive, a CD-ROM drive or an external device as a USB Flash drive. You may configure the order that your computer searches these physical devices for the boot sequence. The first device in the order list has the first boot priority. For example, to boot from a CD-ROM drive instead of a hard drive, place the CD-ROM drive ahead of the hard drive in priority.

While you are in the BIOS Setup Utility, you will not be able to use your mouse. Use the keyboard arrow keys to move around the screen.

To specify the boot sequence:

1. Start the computer and press ESC, F1, F2, F8 or F10 during the initial startup screen. Depending on the BIOS manufacturer, a menu may appear.

2. Choose to enter BIOS setup. The BIOS setup utility page appears.

3. Use the arrow keys to select the BOOT tab. System devices appear in order of priority.

4. To give a CD boot sequence priority over the hard drive, move it to the first position in the list.

· Save and exit the BIOS setup utility. The computer will restart with the changed settings.

PICTURE: Boot Priority Options
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WE HAVE GIVEN YOU SOME EXAMPLES ABOVE OF HOW TO SET YOUR SOFTWARE TO BOOT FROM THE BIOS, SO LET’S MOVE ON:

How to Start & Run your PC Diag software:

1. If you want to run the software from the CD, insert the CD, reboot your system, enter the computer BIOS, and select the CD as the first boot device. The application will start automatically after the boot-up sequence. Important: saving test results understand that you can view, but you can’t write any test results to a CD. In order to save and write test results you need to have a floppy drive in your PC, which would typically be an older PC, or a USB Flash drive attached to one of the ports on the PC. You can select to save and write your test results to your own USB Flash Drive.
Tip: Keep in mind that you’re BIOS, by default, does not support a USB keyboard. Meaning: that if you boot your PC while having a USB keyboard, you will NOT be able to modify anything! As a matter of fact: you won't even be able to get in to the BIOS! So first USE your old PS/2 keyboard to go into the BIOS and set "USB Keyboard Support" to enabled!
VERY IMPORTANT – USB Testing:  If you wish to test your USB ports it must be done from the CD. Also, when running USB tests, the USB keyboard and mouse will be locked. You will need a PS2 keyboard in this case if you are working on a desktop. You have the option which you will see right in the software to not execute USB testing.
Testing the hardware

1. Running a batch test file

Go to the Batch test and select Run Batch Test file. Select the file that you want to run, usually ending in .brn. If the file does not have a log file set, then you can set one from the File->Log menu.

2. Running the quick batch test file

Just press the F5 key, or select to the Batch test -> Quick menu.

3. Running the full batch test file

Just press the F4 key, or select to the Batch test -> Full menu.

4. Creating your own PC Diag custom / predetermined batch test file

Go to the Batch test and select Create/Edit Batch Test file. You can either create a new file or edit an existing batch. You can select the individual tests that you want to include in your batch; you can also add your own company’s custom tests (this is referring to other DOS tests you may have that are not from PC Diag). You can add detailed devices selection, as well as the multiple test parameters (number of passes, time limit, HDD testing time, errors accepted, pausing) and the log file options.

NOTE: You can create up to nine of your own custom/predetermined batch tests and then simply select anyone of them you wish to run at any given time from the menu.

5. Testing components individually

Select the test that you want to run from Tests -> COMPONENT NAME menu.

6. Integrating your company’s own custom DOS tests into PC Diag.

NOTE: If you have your own custom DOS tests that you would like to integrate with tests developed by PC Diag, then you can simply add them into the custom.ini file. This file supports up to 20 custom tests. Once your tests are added to this file, they will appear under the Tests->Custom tests menu. If there are no custom tests in this file, this menu will not be visible. Each custom test has a name and a command line. Below is an example of how the file should look, in this example all these lines are commented out.
       //Name1=<name1>

       //Command1=<command1>

       //Name2=<name2>

       //Command2=<command2>

       //………………………

       //………………………

       //……………………..

       //NameN=<nameN>

       //CommandN=<commandN>

       //whereN<=20

       //

       //Example:

       //Name1=Sound

       //Command1=pcspeak.exe 01.mid

       //It will run the sound test.

Snapshot report

1. To view the snapshot report press F3 or select the Files -> Snapshot menu.

2. To setup snapshot parameters (Owner, Technician, Computer Information, Rating tables, Headings, etc), select the Tools-> Snapshot menu.

Log file

1. To setup the log file as well as logging parameters, please select the Files->Log->initialize/settings menu.

2. To view the log file, select the File->Log->View menu.

3. HDD errors will additionally display on screen: There may be some limitations as to the displayed on screen results based on the number of batches run or on the number of errors per batch.

For example: We know that 200 errors will work for 10 batches. If there are more then this and they do not display on screen you can find the results in the log file.

NOTE: Memory errors will not display on the screen, but you can find them in the log file.

NOTE: In order to view your test results remember you must set up a log file before testing begins. You can’t write your test results to a CD. Also remember you can only write and view your test results if you are saving results to a Floppy/older legacy drive (you can’t save results to an External USB floppy drive). Or you can simply save to a USB Flash Drive.

SAVING A LOG FILE TO YOUR OWN USB FLASH DRIVE.
SAVING TO YOUR OWN DRIVE:

In order to successfully save a log file to your own USB Flash Drive device the following steps must be taken: 

1.   Please make sure your USB Flash Drive is formatted in the FAT16 File System. DOS will not "see" FAT32 or NTFS-formatted USB devices.

If you want to format your drive FAT16, you have to open Windows Explorer to do so.

a. To open Windows Explorer Click on Start

b. Click on Search

c. Go to Files or Folders, Click on It

d. Enter Windows Explorer for your Search

 Once you have found it right click on the USB drive.

WARNING FORMATTING YOUR OWN USB FLASH DRIVE: 

This operation / formatting will delete all the existing information on the disk you are about to select. Make absolutely sure you are selecting to format the USB Flash Drive you have inserted and not a hard drive in your system such as “C”. If you are not familiar with this procedure or it is not clear to you which drive is the USB Flash Drive you have inserted then do the following.

a. Click on Start

b. Then click on my Computer. The USB Flash Drive you have inserted will say Removable Disk look for a picture of the device & note the device letter. It’ll probably will be “E” or higher such as “F” or “G”, but please check to make absolutely sure, you have selected the correct drive.

Now that you have found the correct flash drive you can click (Format).

 In the next screen 

a. Select “FAT” for File System as in the image below, it will not say Fat16, so don’t be confused.
b. Select “Quick Format”

c. Select “Start”

d. A WARNING Window will now appear reminding you that all information on the drive you have selected is about to be removed, Select OK
e. A window will now appear that says “Format Complete” click OK and close out all Windows your USB Flash Drive is now formatted in Fat16. 
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2. With your own USB Flash Drive in any available USB Slot, Enter your BIOS SETUP [usually by pressing DEL as the computer boots up] and check if BIOS displays the USB Flash Drive. If you can see the USB Flash Drive, then WITHOUT removing the USB Flash Drive, start the PC, and run the (PCDiag-DOS) application by CD, once you have completed testing you can save the results of the testing / log file to the your own USB Flash Drive.

3. If you do not see the device for any reason then try to restart the computer with the device attached and try step 2) again. If you have repeated the steps several times and can still not see the USB Flash Drive, then there may be a problem with the USB drive you are unaware of, so replace it with a different USB Flash Drive and start over.

IMPORTANT: DOS will never recognize a USB device if you insert it after the computer has started. You either have the USB device in the SLOT at power-on or it will not work. 

Settings

1. To setup testing parameters, please select Tools->Options menu, then select Test settings.

2. To setup snapshot parameters (Owner, Technician, Computer Information, Rating tables, Headings, etc), select the Tools-> Snapshot menu.

Startup parameters

1. In order to run the software application with parameters, the user must modify the autoexec.bat file from the menu "Files -> Edit configuration files" or the application can run directly from DOS command line (ex.: pcdiag help).

2. The following is the command line format:

PCDIAG [T:filename [/SM] [/SR] ] [X:filename [/SM] [/SR]] [L:filename] [Q] [F] [SNAPSHOT[:filename] [SNAPSHOTOUTPUT:filename [/SO] ] [/SMLW] [README] [HELP]

Where:

    [T:filename] - allows loading and running of a batch file (ex.: PCDIAG T: COMPLET.BRN). The only      functional batch files are those previously created by this software application. Batch files are created from the menu "Batch tests -> Create/Edit batch file".

    [X:filename] - allows loading a multi batch file at startup (ex.: PCDIAG X: CHOICE.BRX). A BRX file is a collection of batch files created with PCDiag. When the program is started with the X switch, the user will be presented with a menu and asked to select from one of the batches in the BRX file. 


Below is an example of a BRX file:


PCDiagQuick.brn=Quick Test


PCDiagFull.brn=Full Test


PCDiagHDD.brn=Hard Drive Test

    [L:filename] - test results from the session accessed by means of this parameter will be placed in the "filename" file (ex.: PCDIAG L:TESTS.LOG). The file extension can be any type.

    [Q] - performs a quick test for all of the computer components (ex.: PCDIAG Q)

    [F] - performs all tests that do not require interaction with the user for all the existing components (ex.: PCDIAG F)

    [SNAPSHOT[:filename] displays the information from the Snapshot report with either standard settings or those loaded from the "filename" (ex.: PCDIAG SNAPSHOT:filename). The file will be loaded and used only if it has been previously created by the software application. In order to create a snapshot settings file, press F3 when in the Snapshot report, modify settings and press "Save settings" or from the menu "Tools -> Snapshot settings -> Save settings".

   [SNAPSHOTOUTPUT:filename] – displays the information from the Snapshot report with the default settings and writes the collected information to the file “filename” (ex PCDIAG SNAPSHOTOUTPUT: filename).

   [/SO] – used with SNAPSHOTOUTPUT, when running a Snapshot report this option automatically exits to DOS after the snapshot is finished also automatically overwriting the output file “filename” with no warning message. (ex: PCDIAG SNAPSHOTOUTPUT: filename /SO)

   [/SM] - Display a menu with choice for Print, View, Save at the end of a Batch test

   [/SR] - Display status report at the end of a Batch test.

   [/SMLW] - Do not display the Module Load Warning.

    [README] - loads the help file under html format (ex.: PCDIAG README)

    [HELP] - displays the command line options

Tools & Benchmarks

1. The Tools menu will offer you the following Hard drive tools:

· Park heads

· Check disk allocation

· Scan drive for bad sectors

· Refresh drive

· Format drive

· Refurbish drive

· DOD security erase drive data

2. You can benchmark the system performance using the Benchmark menu.

3. You can view the IRQ and DMA assignments using the File->IRQ and DMA menu. Also you can edit the configuration files using Files -> Edit configuration files.

Help

1. You can obtain help at any time by pressing F1 or by using the Help menu.

